Создание формулы в excel: Создание формулы с помощью функции

Создание формулы с помощью функции

Excel для Интернета Еще…Меньше

Вы можете создать формула для вычисления значений на вашем компьютере с помощью функция. Например, в формулах =СУММ(A1:A2) и СУММ(A1;A2) для с суммы значений в ячейках A1 и A2 используется функция СУММ. Формулы всегда начинаются со знака равно(=).

  1. Щелкните ячейку, в которой нужно вжать формулу.

  2. Чтобы начать формулу с функции, щелкните в или начните вводить формулу в ячейку.

    Совет:  Список доступных функций см. в списках функций (по алфавиту) или функций (по категориям).

  3. org/ListItem»>

    После ввода аргументов формулы нажмите ввод, чтобы увидеть результат формулы в ячейке.

Совет:  Если функции используются часто, можно ввести формулы непосредственно на листе. После того как вы введите знак равных (=) и имя функции, вы увидите сведения о синтаксисе формулы и аргументах функции.

Используйте эти данные для работы с примерами формул с помощью функции. Вы можете видеть и изменять формулы, а также вводить собственные.

Скопируйте таблицу в ячейку A1 пустого листа, чтобы работать с примерами формул, в которые используются функции.

Данные

5

4

2

6

3

8

7

1

Формула

Описание

Результат

‘=СУММ(A:A)

Сумма всех чисел в столбце A

=СУММ(A:A)

‘=СРЗНАЧ(A1:B4)

Среднее арифметическое всех значений в диапазоне A1:B4

=СРЗНАЧ(A1:B4)

Создание простой формулы — Служба поддержки Майкрософт

Excel для Интернета Еще.

..Меньше

Вы можете создать простую формулу для с суммы, вычитания, умножения и деления значений на вашем компьютере. Простые формулы всегда начинаются со знака равной(=),за которым следуют константы, которые являются числами и операторами вычислений, такими как «плюс»(+),«минус»(-),«звездочка»*или «косая черта»(/)в начале.

Например, при вводе формулы =5+2*3последние два числа умножаются и добавляются к первому числу, чтобы получить результат. В стандартном порядке математических операций умножение выполняется перед с добавлением.

  1. На сайте щелкните ячейку, в которой вы хотите ввести формулу.

  2. Введите знак =(знак равно), за которым следуют константы и операторы, которые вы хотите использовать в вычислениях.

    В формулу можно ввести до 8192 знаков.

    Совет: Вместо того чтобы вводить константы в формулу, вы можете выбрать ячейки (например, B12:B15), содержащие нужные значения, и ввести операторы между ними.

  3. Нажмите клавишу ВВОД.

    Примечания: 

    • Чтобы быстро сложить значения, можно использовать авто сумму, а не вводить формулу вручную(вкладка «Главная», группа «Редактирование»).

    • Для вычисления значений на вашем компьютере также можно использовать функцию (например, функцию СУММ).

    • Чтобы сделать это на один шаг дальше, используйте в формуле ссылки на ячейки вместо фактических значений в простой формуле.

В приведенной ниже книге показаны примеры простых формул. Вы можете изменить любую из существующих формул или ввести собственные, чтобы узнать, как они работают и посмотреть результаты.

Данные

2

5

Формула

Описание

Результат

‘=A2+A3

Сумма значений в ячейках A1 и A2

=A2+A3

‘=A2-A3

Разность значений в ячейках A1 и A2

=A2-A3

‘=A2/A3

Частное от деления значений в ячейках A1 и A2

=A2/A3

‘=A2*A3

Произведение значений в ячейках A1 и A2

=A2*A3

‘=A2^A3

Значение в ячейке A1 в степени, указанной в ячейке A2

=A2^A3

Формула

Описание

Результат

‘=5+2

Сумма чисел 5 и 2

=5+2

‘=5-2

Разность чисел 5 и 2

=5-2

‘=5/2

Частное от деления 5 на 2

=5/2

‘=5*2

Произведение чисел 5 и 2

=5*2

‘=5^2

Число 5 во второй степени

=5^2

Использование операторов вычисления в формулах Excel

Excel для Microsoft 365 Excel 2021 Excel 2019 Excel 2016 Excel 2013 Excel 2010 Excel 2007 Дополнительно. .. Меньше

Операторы определяют тип вычисления, которое необходимо выполнить для элементов формулы. Excel следует общим математическим правилам для вычислений, а именно: Скобки , Экспоненты , Умножение и деление и Сложение и вычитание или аббревиатура PEMDAS (Пожалуйста, извините, моя дорогая тетя Салли). Использование круглых скобок позволяет изменить порядок вычислений.

Типы операторов. Существует четыре различных типа операторов вычисления: арифметический , сравнение , конкатенация текста и ссылка .

  • Арифметические операторы

    Для выполнения основных математических операций, таких как сложение, вычитание, умножение или деление; комбинировать числа; и получить числовые результаты, используйте следующие арифметические операторы.

    93

    Арифметический оператор

    Значение

    Пример

    + (плюс)

    Дополнение

    =3+3

    – (знак минус)

    Вычитание
    Отрицание

    =3–3
    =-3

    * (звездочка)

    Умножение

    =3*3

    / (косая черта)

    Отдел

    = 3/3

    % (знак процента)

    Процент

    30%

  • Оператор сравнения

    Значение

    Пример

    = (знак равенства)

    равно

    =А1=В1

    > (знак больше)

    Больше

    =А1>В1

    < (знак меньше)

    Менее

    =А1<В1

    >= (знак больше или равно)

    Больше или равно

    =А1>=В1

    <= (знак меньше или равен)

    Меньше или равно

    =А1<=В1

    <> (без знака равенства)

    Не равно

    =А1<>В1

  • Текстовый оператор

    Значение

    Пример

    и (амперсанд)

    Соединяет или объединяет два значения для создания одного непрерывного текстового значения

    =»Север»&»ветер» приводит к «Борей».
    Где A1 содержит «Фамилия», а B1 содержит «Имя», = A1 &», «& B1 приводит к «Фамилия, Имя».

  • Эталонные операторы

    Объедините диапазоны ячеек для вычислений со следующими операторами.

    Справочный оператор

    Значение

    Пример

    : (двоеточие)

    Оператор диапазона, который создает одну ссылку на все ячейки между двумя ссылками, включая две ссылки.

    В5:В15

    , (запятая)

    Оператор объединения, объединяющий несколько ссылок в одну ссылку

    =СУММ(B5:B15;D5:D15)

    (пробел)

    Оператор пересечения, который создает одну ссылку на ячейки, общие для двух ссылок

    В7:Д7 С6:С8

Автоматически нумеровать строки — Служба поддержки Майкрософт

В отличие от других программ Microsoft 365, в Excel нет кнопки для автоматической нумерации данных. Но вы можете легко добавлять последовательные числа к строкам данных, перетаскивая маркер заполнения, чтобы заполнить столбец серией чисел, или с помощью функции ROW.

Совет:  Если вы ищете более совершенную систему автоматической нумерации для своих данных и на вашем компьютере установлен Access, вы можете импортировать данные Excel в базу данных Access. В базе данных Access можно создать поле, которое автоматически генерирует уникальный номер при вводе новой записи в таблицу.

Что ты хочешь сделать?

  • Заполните столбец серией чисел

  • Используйте функцию ROW для нумерации строк

  • Показать или скрыть маркер заполнения

Заполнить столбец серией цифр

    org/ItemList»>
  1. Выберите первую ячейку в диапазоне, который вы хотите заполнить.

  2. Введите начальное значение серии.

  3. Введите значение в следующую ячейку, чтобы установить шаблон.

    Совет: Например, если вы хотите получить ряд 1, 2, 3, 4, 5…, введите 1 и 2 в первых двух ячейках. Если вам нужны серии 2, 4, 6, 8…, введите 2 и 4 .

  4. Выберите ячейки, содержащие начальные значения.

    Примечание. В Excel 2013 и более поздних версиях кнопка Быстрый анализ отображается по умолчанию, когда вы выбираете более одной ячейки, содержащей данные. Вы можете игнорировать кнопку, чтобы завершить эту процедуру.

  5. Перетащите маркер заполнения через диапазон, который вы хотите заполнить.

    Примечание. Когда вы перетаскиваете маркер заполнения по каждой ячейке, Excel отображает предварительный просмотр значения. Если вам нужен другой узор, перетащите маркер заполнения, удерживая нажатой правую кнопку, а затем выберите узор.

    Чтобы заполнить в порядке возрастания, перетащите вниз или вправо. Чтобы заполнить в порядке убывания, перетащите вверх или влево.

    Совет:  Если вы не видите маркер заполнения, возможно, вам придется сначала отобразить его. Дополнительные сведения см. в разделе Отображение или скрытие маркера заполнения.

    Примечание. Эти номера не обновляются автоматически при добавлении, перемещении или удалении строк. Вы можете вручную обновить последовательную нумерацию, выбрав два числа в правильной последовательности, а затем перетащив маркер заполнения в конец пронумерованного диапазона.

Используйте функцию ROW для нумерации строк

  1. В первой ячейке диапазона, который вы хотите пронумеровать, введите =СТРОКА(A1) .

    Функция ROW возвращает номер строки, на которую вы ссылаетесь. Например, =СТРОКА(A1) возвращает число 1 .

  2. Перетащите маркер заполнения через диапазон, который вы хотите заполнить.

    Совет:  Если вы не видите маркер заполнения, возможно, вам придется сначала отобразить его. Дополнительные сведения см. в разделе Отображение или скрытие маркера заполнения.

  • Эти числа обновляются, когда вы сортируете их с вашими данными. Последовательность может быть прервана, если вы добавляете, перемещаете или удаляете строки. Вы можете вручную обновить нумерацию, выбрав два числа в правильной последовательности, а затем перетащив маркер заполнения в конец пронумерованного диапазона.

  • Если вы используете функцию ROW и хотите, чтобы числа вставлялись автоматически при добавлении новых строк данных, превратите этот диапазон данных в таблицу Excel. Все строки, добавляемые в конец таблицы, нумеруются последовательно. Дополнительные сведения см. в статье Создание или удаление таблицы Excel на листе.

Чтобы ввести определенные последовательные числовые коды, такие как номера заказов на поставку, вы можете использовать ROW вместе с функцией TEXT . Например, чтобы начать нумерованный список с помощью 000-001 , введите формулу =ТЕКСТ(СТРОКА(A1);»000-000″) в первую ячейку диапазона, который вы хотите пронумеровать, и затем перетащите маркер заполнения в конец диапазона.

Показать или скрыть маркер заполнения

Маркер заполнения отображается по умолчанию, но вы можете включить или выключить его.

  1. В Excel 2010 и более поздних версиях щелкните вкладку Файл и щелкните Параметры .

    В Excel 2007 нажмите кнопку Microsoft Office , а затем щелкните Параметры Excel .

Оставить комментарий

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *